はじめに

いまさらながら、Ubuntu の phpMyAdminのアラート回避の話。

現象

Ubuntu で phpMyAdminをインストールすると、以下のアラートが出る。

リンクテーブルを処理するための追加機能が無効になっています。理由についてはこちらをご覧ください

インストールしただけでは、設定が不完全なようだ。

対処

対処方法は、phpMyAdmin 初期設定メモにあったので、その通りしてみた。

管理用テーブル(phpmyadmin)の作成

1. zcat /usr/share/doc/phpmyadmin/examples/create_tables.sql.gz > /tmp/create_tables.sql
2. mysql -u [mysql管理者ID] -p < /tmp/create_tables.sql 3. rm /tmp/create_tables.sql /etc/phpmyadmin/config-db.php 編集 $dbname=”; を $dbname=’phpmyadmin’; に変更 /etc/phpmyadmin/config.inc.php 編集 $cfg['Servers'][$i]['designer_coords'] = ‘pma_designer_coords’; の下に $cfg['Servers'][$i]['tracking'] = ‘pma_tracking’; を追記

アラートが解消された。kuniharumaki blogの中の方、有益な情報の提供に感謝です。